MacOSX86の夢を語ろう!第50夜

1名称未設定 (8級) (ワッチョイ fbd1-+T17)2018/01/27(土) 02:39:12.52ID:OY5LB1UE0
PC/AT互換機でMac OS Xが動くという夢を見た人が語ろう

■注意
ライセンス論、著作権論、法律論は他のスレでお願いします

■インストール前の注意
OSX86は、DOSV機と異なり、動作するパーツがごく一部のみに限られます

■質問する前に
・既出の話題が多いので、まずスレ内や過去ログを検索しましょう(過去ログはOSx86jpにあります)
・OSX86固有とは思われない質問はmacOSスレのほうでお願いします
・海外フォーラムに頼らずに、日本語でお手軽に情報を得ようとして質問するなら
 CPU/マザーボードなどのパーツのスペックや型番も明記しましょう
・あなたの前提だと思っている事柄はわかりません。手順を含め正確に伝えましょう
 その手間が面倒ならば海外フォーラムに答えはほぼ全てありますのでそちらでどうぞ
・このスレッドで質問にわざわざ答えていただいてるみなさん、ありがとうございます

前スレ
MacOSX86の夢を語ろう!第49夜
http://egg.5ch.net/test/read.cgi/mac/1505020919/
VIPQ2_EXTDAT: default:vvvvv:1000:512:----: EXT was configured

20名称未設定 (ワッチョイ 9fd1-6jl+)2018/02/07(水) 23:10:05.73ID:xDftDj170
>>18
フォーラムなどを読んで得たUSBに関するわたしの理解です
間違っているよとか、もっといまは便利な方法があるよとか、
教えていただければありがたいです

21名称未設定 (ワッチョイ 79d1-5l5M)2018/02/09(金) 21:46:09.46ID:txx21mkF0
10.13.4 betaに関すること
ttp://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-2#entry2576719

22名称未設定 (ワッチョイ 79d1-5l5M)2018/02/09(金) 21:58:29.59ID:txx21mkF0
10.13.4 beta で USBポートの制限に関するパッチの記述が変更になったみたいです
いまのところ暫定ではあるのでしょうが beta を試される方は参考に
ttp://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-4#entry2577886

23名称未設定 (ワッチョイ 79d1-5l5M)2018/02/10(土) 02:07:14.01ID:TnxxcG6f0
10.13.4 beta で USBポートの制限に関するパッチの記述が変更になったみたいです
いまのところ暫定ではあるのでしょうが beta を試される方は参考に
ttp://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-4#entry2577886

24名称未設定 (ワッチョイ 79d1-5l5M)2018/02/10(土) 02:07:43.71ID:TnxxcG6f0
>>23
ごばく

25名称未設定 (ワッチョイ 42d1-5l5M)2018/02/10(土) 10:27:54.42ID:6dIGMZ4h0
10.13.4 beta で 今のところ Intel HD 4000 がプロファイルでGPUが二つ表示されるけど
次期Cloverで修正される予定です
ttp://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-12#entry2588197

26名称未設定 (ワッチョイ add1-5l5M)2018/02/11(日) 01:26:32.69ID:yVmnpoNr0

27名称未設定 (ワッチョイ add1-5l5M)2018/02/12(月) 00:24:54.97ID:KwwaMqTi0
>>25
4414バージョンで一応の対策がとられました
ttps://sourceforge.net/p/cloverefiboot/code/4414/

28名称未設定 (ワッチョイ add1-5l5M)2018/02/12(月) 20:41:29.10ID:2i7eFzsH0
10.13.4 beta 用の EIST パフォーマンス用のカーネルパッチ
ttp://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-13#entry2590343

29名称未設定 (ワッチョイ e5f7-Yy9d)2018/02/13(火) 16:19:19.38ID:MUk2+LTN0
10.13.3にしてから
しばらくすると動作がカクカクになるので
調べてたら
CloverのOsxAptioFix2Drv-64
をOsxAptioFix3Drv-64にと言う書き込みを発見しました。
結果改善しました。
7700Kと1060です。
報告まで

30名称未設定 (ワッチョイ 79d1-5l5M)2018/02/13(火) 16:27:05.88ID:2tFTCf9j0
>>29
>26
のAptioMemoryFixは試されましたか?

31名称未設定 (ワッチョイ e5f7-Yy9d)2018/02/13(火) 16:53:38.96ID:MUk2+LTN0
>>30
まだです。
確認してからテストしてみたいと
思います
ありがとうございました

32名称未設定 (ワッチョイ e5f7-Yy9d)2018/02/13(火) 17:02:06.46ID:MUk2+LTN0
>>31です。

AptioMemoryFixが一番良いのかな?
今それに切り替えてテストしてみます。
ASUS Z270H

33名称未設定 (ワッチョイ 79d1-5l5M)2018/02/13(火) 21:05:11.06ID:2tFTCf9j0
>>32
新しいCPU/マザーボードのハードでの検証、ありがとうございます!

34名称未設定 (ワッチョイ e5f7-Yy9d)2018/02/13(火) 21:10:40.31ID:MUk2+LTN0
>>33
AptioMemoryFixに変更後
主にDAWをメインに
数時間使ってみましたが
今の所問題なさそうです。
以前感じられたカクカク感も
なくなったように感じられます。

35名称未設定 (ワッチョイ 79d1-5l5M)2018/02/13(火) 23:33:55.89ID:2tFTCf9j0
AptioMemoryFix.efi の最新版をマニュアルでビルドしてみました(大いに間違っている可能性はあります)

cd ~/
mkdir src (なければ)
cd src
svn co https://github.com/vit9696/AptioFixPkg.git AptioFixPkg
cd ~/src/AptioFixPkg/trunk
./macbuild.tool
open ~/src/AptioFixPkg/trunk/binaries/RELEASE (Finder が開いたディレクトリに AptioMemoryFix.efi があります)

ビルドした AptioMemoryFix.efi EFI に入れて起動できました(バージョンは R15)
ちなみに Clover の配布版の最新版(4411)に同梱されているバージョンは R12 なので、
同梱版の方には検証がとられていると思われます

上記方法は間違っている可能性があると思われるので、
beta 版などで不具合を検証した時などに有効かもしれません(自己責任でどうぞ)

36名称未設定 (ワッチョイ 79d1-5l5M)2018/02/14(水) 02:17:25.72ID:3RtZvthl0
現行の Mac では廃止されてしまった電源オン時のブートサウンド(Chime)がありますが
hackintosh で実現しようとしたら、
↓ハード的に電子工作的なものが必要でした
ttp://www.insanelymac.com/forum/topic/287353-tutorial-adding-the-apple-chime-to-your-hackintosh/
ttps://www.youtube.com/watch?v=K-30MYAnd-0

下記の部品を最近みかけたので、お手軽に Chime 音を鳴らせるかもしれないと思い、
機会があればチャレンジしてみたいです
ttps://akiba-pc.watch.impress.co.jp/docs/news/news/1099282.html
ttp://ascii.jp/elem/000/001/625/1625331/

37名称未設定 (ワッチョイ add1-5l5M)2018/02/14(水) 23:39:43.80ID:BFPKlMGz0
ご存知の方も多いと思いますが
Clover に apfs.efi を設置すると
一瞬だけ詳細情報が Clover ブート時に表示されます
表示される分には何ら問題はないのですが、
その表示を apfs.efi のパッチを当てて消す方法があります

オリジナルを残したい場合はあらかじめコピー
mkdir ~/apfs (なければ)
cp /path/to/your/apfs.efi ~/apfs
perl -i -pe 's|\x00\x74\x07\xb8\xff\xff|\x00\x90\x90\xb8\xff\xff|sg' ~/apfs/apfs.efi

パッチは現在 10.13.4 beta 1 でも有効みたいです
今後変わる可能性があるので、うまくいかない場合は
↓下記を参照するといいと思われます
ttp://www.insanelymac.com/forum/topic/327584-apfsefi-without-verbose-boot/page-5#entry2532527

38名称未設定 (ワッチョイ 37d1-lXbm)2018/02/15(木) 02:37:47.28ID:56lxl/7R0
High Sierra 10.13.2 では OOB で 10Gb のイーサネットが動くようになったカードがあるんですね
ttp://www.insanelymac.com/forum/topic/330614-success-aqc107-10-gbe-native-support-in-high-sierra-10132/

39名称未設定 (ワッチョイ ff5c-xmwW)2018/02/15(木) 07:22:24.86ID:OfDYt0TR0
AQtion AQC107  
iMac Pro様様っすな 

此処の住人にほとんどよりiMac Proのほうが性能高いっていう

40名称未設定 (ワッチョイ 97d1-lXbm)2018/02/15(木) 08:14:56.73ID:Sdola+ew0
>>22
検証用の外付け USB HDD の 10.13.3 beta 6 を 10.13.4 beta 2 にアップデートしました
確かに 10.13.4 beta では USB 制限パッチが効かなくなっており、起動できませんでした
(10.13.3 環境では IORegistryExplorer 上では20番目にアサインされた USBポート に接続した USB HDD)
そこで、参照URLをもとに、15制限から20制限にするパッチをつくって試してみました
表記は Clover Configurator でのことです

KextsToPatch
Name <AppleUSBXHCI>
Find <837d940f 0f839704>
Replace <837d9414 0f839704>
Comment <High Sierra(10.13.4 - ) 15 to 20>
MatchOS <10.13.4>

上記で 10.13.4 beta 2 環境で無事に起動しました
(10.13.4 beta 環境でも同様に IORegistryExplorer 上では20番目にアサインされました)
参考になればと思います

41名称未設定 (ワッチョイ 97d1-lXbm)2018/02/15(木) 08:22:19.74ID:Sdola+ew0
>>39
iMac Pro に採用されたボードなんですね
Aquantia って Intel のブランド名かと思ったら
そのものずばり会社なんですね、知りませんでした

42名称未設定 (ワッチョイ ff5c-xmwW)2018/02/16(金) 02:49:49.04ID:IgTaPArk0
HSiera 最新 RX480ポラリス環境でLrCC Classic最新版一個前も
下に表示される横長ライブラリを矢印キーで移動してたらかなりの確率でアプリ落ちて
再起動したらGPUのアクセレーションがOFFになってる 

頻繁に落ちる 

43名称未設定 (ワッチョイ 97d1-lXbm)2018/02/16(金) 23:12:32.18ID:/Ob99NNv0
>>42
LrCC Classic というのはソフトウェアはわたしはつかっていないので
わかりませんが、hackintosh 固有のことなのでしょうか?
環境がわからないので何も言えません
頻繁に落ちるという報告でなく、改善されたいのでしょうか?

44名称未設定 (ワッチョイ ff5c-xmwW)2018/02/17(土) 04:01:17.07ID:CKx59YmI0
>>43
改善されてないですよ もっと前のバージョンで落ちなかった

写真アプリで言うとサムネ表示、高速スクロールで動かしたらいきなり落ちる感じ 編集とかでは落ちない
GPU周りHackintosh固有の可能性があると疑ってる
GPU使わないと落ちないけど体感遅くなる

45名称未設定 (ワッチョイ 97d1-lXbm)2018/02/17(土) 05:00:58.27ID:19QTAqi60
>>44
なるほどです
改善されたいのですか?ってお尋ねしたつもりでした
伝わらずに申し訳ないです

RX480といったGPUをつかっておりませんので
>>21
の参照を見てみると
10.13.4 beta では WhatEverGreen や RadeonDeInit 等が必要なくなったとあります
なので、もっとネイティブ動作すればいいですねという
観測しかいまのところ言えずすいませんです

46名称未設定 (オイコラミネオ MM4f-vd6b)2018/02/17(土) 14:32:38.41ID:SDGPrfkjM
>>44
Adobe + AMDはWindowsでも落ちるらしいから改善されるまで待つしかないのでは?
https://youtu.be/MFJPMFdSlF8?list=PLZRpVgG187Cuig2udV_OWTwQGkVE3L6f4&t=628

47名称未設定 (ワッチョイ 9fd1-lXbm)2018/02/18(日) 00:39:31.43ID:Sd/PJXKT0
今のところ Apple 純正では AMD のプロセッサをサポートしていなくて
hackintosh の是非はあるとは思いますが、
最新の Ryzen 2200G で iGPU を含めて動作したとのことです
ttp://www.insanelymac.com/forum/topic/332740-amd-ryzen-2200g-with-vega-graphics-hackintoshable/

48名称未設定 (ワッチョイ f7f7-xmwW)2018/02/21(水) 07:23:29.11ID:mA148tAg0
10.13.3にしてから
しばらく使っていると
カクつく症状出る。

AptioMemoryFixにしてもダメ
メモリーの解放をすると気持ち
少しの間だけ改善される気がする


ASUS Z270H
1060 6GB
7700K

49名称未設定 (ワッチョイ 97d1-lXbm)2018/02/21(水) 09:46:39.42ID:CKMGd87j0
>>48
・10.13.3 より前なら症状はでないのでしょうか?
・切り分けのために新規アカウントを作ってテストユーザで試されましたか?

そして
MaLd0nさんに RunMe.app をつかって見てもらったら手っ取り早いのではないでしょうか
ttp://www.insanelymac.com/forum/topic/321872-guide-sierra-high-sierra-on-mobos-serie-100-200-300-skylake-kabylake-coffeelake-dsdt/

50名称未設定 (ワッチョイ f7f7-xmwW)2018/02/21(水) 10:12:35.64ID:mA148tAg0
>>48
別のSSDから(バックアップ用 10.13.2)
起動すると明らかに問題なし。

51名称未設定 (ワッチョイW 5727-Z2ua)2018/02/21(水) 12:33:56.69ID:FpmcfMUA0
>>50
13.3 のnvidia driverにバグがある、と海外フォーラムで目にしたよ
一度iGPUで試したらどう?

俺も1060 6GB使ってたけど、スリープ復帰でグリッチでたり、UIが少しラグったり、同じ報告も何件か目にしたから、pascal世代でも1060は問題出やすい気がする

52名称未設定 (ワッチョイ f7f7-xmwW)2018/02/21(水) 12:44:18.15ID:mA148tAg0
>>51
フォーラムで自分と同じ問題抱えている人を
見かけるので、確認中
ChromeやSafariを開くとカクカク
Logic Proは若干のカクカク

>>iGPUで試してみたらどう?
この辺も確認してみます


ありがとう

53名称未設定 (ワッチョイ bfac-K9J4)2018/02/21(水) 21:05:18.73ID:vfticWuJ0
>>48
お、ちょうど俺にタイムリーなレス
13.3からかどうか分からんが先日UHDディスプレイが届いて、750Tiで使用すると異様にカクツク。
単に性能不足なだけかもしれんが、特にLaunchpadとかが酷い。
だれかNVIDIAのボードでUHDが快適に動くグラボがあったら教えてくれ。

54名称未設定 (JPWW 0H7f-ijx1)2018/02/21(水) 21:32:26.65ID:b2rPKARLH
>>53
gtx970使ってるけど全く問題ないよ

55名称未設定 (JPWW 0H7f-ijx1)2018/02/21(水) 21:35:55.56ID:b2rPKARLH
ってか、グラボ買い直さなくても10.13.2のwebdriverに戻して、ビルドを誤魔化して動かせばその問題は出ないね

56名称未設定 (ワッチョイ 97d1-lXbm)2018/02/21(水) 22:06:51.22ID:kHSt4Ye90
>>55
貴重な情報ありがとうございます
わたしは WebDriver が必要なほど
高価な GPU つかっていないので (GT 710 1GB です)
こういった情報はありがたいです

57名称未設定 (ワッチョイ 7dd1-C6Oa)2018/02/22(木) 04:21:31.14ID:Cq3zwMLO0
ttps://www.reddit.com/r/hackintosh/comments/7z3bbp/nvidia_web_driver_release_17d102_and_17d2102/

に The new 17D102 fixed the lag issue on my GTX 1080
とあるので新しい WebDriver には改善された部分があるのかもですね

58名称未設定 (ワッチョイ 35f7-Mlo3)2018/02/22(木) 11:07:07.35ID:EmPnQJNX0
ダメだわ

しばらく使うと
カクカクする
10.13.3(17D102)

色々検証中

59名称未設定 (ワッチョイ e2d1-C6Oa)2018/02/23(金) 01:40:58.82ID:8pO/2BIE0
Clover 4416 で firmware の SMBIOS 更新がきていますね
自動取得している人はそのままで最新情報が取得できそうです

60名称未設定 (ワッチョイ 35f7-Mlo3)2018/02/23(金) 16:47:03.34ID:/mFEelHy0
>>58
アクセス権の修復で
良くなった?
気がする。
OsxAptioFix3Drv-64にて
テスト中

61名称未設定 (スップ Sd00-SIZ4)2018/02/23(金) 20:28:33.63ID:AFnCReuhd
MacOS X86ってVegaとかGTX1080Ti SLIサポートしてるよね?

62名称未設定 (ワッチョイ e2d1-C6Oa)2018/02/23(金) 20:49:15.00ID:F6nBcyoS0
>>61
質問がいまいち伝わりにくかったので

hackintosh で
・Vega は サポートされていますか
・1080 Ti で SLI はサポートされていますか
・Vega と 1080 Ti のどちらかで SLI はサポートされていますか

これらのうちのどれかでしょうか?

63名称未設定 (ワッチョイ e2d1-C6Oa)2018/02/24(土) 00:24:03.73ID:t/GiUTJX0
>>15
をもとに最新の Clover 4416 をビルドしました
できあがった Clover_v2.4k_r4416.pkg には
Drivers64UEFI - AptioMemoryFix は含まれていませんでした
最新版にこだわるなら必要に応じて
>>35
も利用する必要があるのかもです

64名称未設定 (ワッチョイW 3f56-74NA)2018/02/24(土) 00:37:16.04ID:kZlZnwdL0
>>62
アスペ

65名称未設定 (ワッチョイ 965c-Mlo3)2018/02/24(土) 23:36:08.89ID:E+A7DYZM0
画面分割して処理するCFやSLは対応してない
マルチGPUは対応してるけどごく一部のアプリのみ

VegaはiMac Proが出たからベンチはちゃんと出るけど
おそらく純正と同じ挙動しないんじゃない? 

66名称未設定 (ワッチョイ 7a4a-Mlo3)2018/02/25(日) 11:17:04.89ID:gsTOrAdP0
17D102にアップデート後にwebdriverも158にしたらカクカク
106に切り替えたらたら黒画面でGUIに辿りつけず…
リモートログインしてドライバをアンインストールして再起動
CloverでCSRを0x67から0x00に戻して起動後に158をインストール
CSRは0x00のままで再起動したら158でカクカクが改善された気がします
それでもラグい感じは残っているのですが、以前からそうだったので我慢して使って見ます

8700k / Asus z370 / 1080ti / 4K HDPI

67名称未設定 (ワッチョイ 35f7-Mlo3)2018/02/25(日) 11:38:19.14ID:ewz1Xr0u0
>>66
ダメでしたか…..
自分も色々試していますが
解決されず

7700k/ASUS Z270 /1060/

68名称未設定 (ワッチョイ 46d1-C6Oa)2018/02/25(日) 17:57:39.51ID:7YATvROV0
>>66
>>67
参照URLを読むとマザーボードが 100/200/300 シリーズだと起こる問題なのでしょうか?
なにか新しいアイデアが浮かんでいると期待しています
ttp://www.insanelymac.com/forum/topic/332704-nvidia-gpus-and-the-infamous-lag-issue-why-is-that-happening/page-4#entry2597285

69名称未設定 (ワッチョイ 7a4a-Mlo3)2018/02/25(日) 20:26:33.23ID:gsTOrAdP0
>>68
そのようですね、Skylakeより前の世代ではスムーズに動作しているようです

RX580がもう少し手頃になれば乗り換えたいんですけどね…

70名称未設定 (JPWW 0H32-RynM)2018/02/25(日) 20:47:09.04ID:07LxcWhyH
安定のHaswell変わらずか

新着レスの表示
レスを投稿する